Vulnerability · Published May 12, 2026 · Assigned by apache

CVE-2026-43515Apache Tomcat: Security constraints not correctly applied

Critical 9.1

In plain English

A critical-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)1.2%top 31.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10tomcat1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-admin-webapps1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-admin-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-docs-webapp1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-docs-webapp1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-el-3.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-el-5.0-api1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-jsp-3.1-api1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:10tomcat-lib1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-lib1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat-servlet-6.0-api1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:10tomcat-webapps1:10.1.49-4.el10_2.alma.1ALSA-2026:69259
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat91:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-admin-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-docs-webapp1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-el-3.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-lib1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
Debian:12tomcat1010.1.55-1~deb12u1DEBIAN-CVE-2026-43515
Debian:13tomcat1010.1.55-1~deb13u1DEBIAN-CVE-2026-43515
Debian:14tomcat1010.1.55-1DEBIAN-CVE-2026-43515
Debian:13tomcat1111.0.22-1~deb13u1DEBIAN-CVE-2026-43515
Debian:14tomcat1111.0.22-1DEBIAN-CVE-2026-43515
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-43515
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-43515
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-43515
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.55GHSA-5m62-pw8w-7w9f
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.22GHSA-5m62-pw8w-7w9f
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.118GHSA-5m62-pw8w-7w9f
Mavenorg.apache.tomcat:tomcat11.0.22GHSA-5m62-pw8w-7w9f
Mavenorg.apache.tomcat:tomcat9.0.118GHSA-5m62-pw8w-7w9f
Mavenorg.apache.tomcat:tomcat10.1.55GHSA-5m62-pw8w-7w9f
Mavenorg.apache.tomcat:tomcat-catalina11.0.22GHSA-5m62-pw8w-7w9f
Mavenorg.apache.tomcat:tomcat-catalina10.1.55GHSA-5m62-pw8w-7w9f
Mavenorg.apache.tomcat:tomcat-catalina9.0.118GHSA-5m62-pw8w-7w9f
Rocky Linux:10tomcat1:10.1.49-4.el10_2RLSA-2026:69259
Rocky Linux:8tomcat1:9.0.120-1.el8_10RLSA-2026:68677
Rocky Linux:9tomcat1:9.0.120-2.el9_8RLSA-2026:68660
Rocky Linux:10tomcat91:9.0.120-1.el10_2RLSA-2026:68651
Ubuntu:25.10tomcat1010.1.40-1ubuntu1.25.10.1UBUNTU-CVE-2026-43515
Ubuntu:26.04:LTStomcat1010.1.40-1ubuntu1.26.04.1UBUNTU-CVE-2026-43515
Ubuntu:25.10tomcat11no fix listedUBUNTU-CVE-2026-43515
Ubuntu:25.10tomcat99.0.95-1ubuntu1.1UBUNTU-CVE-2026-43515
Ubuntu:26.04:LTStomcat99.0.115-1ubuntu0.1UBUNTU-CVE-2026-43515

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2110.1.0-M1 – through 10.1.549.0.0.M1 – through 9.0.1178.5.0 – through 8.5.1007.0.0 – through 7.0.109

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References