Vulnerability · Published May 25, 2026 · Assigned by apache

CVE-2026-42782Apache Syncope: Post-auth RCE via Groovy static

High 7.2

In plain English

A high-severity security flaw in Apache Syncope from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.2High
Exploit odds (30 days)0.7%top 48.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.syncope.core:syncope-core-springno fix listedGHSA-gq7g-vg2q-jvq3
Mavenorg.apache.syncope.core:syncope-core-spring4.0.6GHSA-gq7g-vg2q-jvq3
Mavenorg.apache.syncope.core:syncope-core-spring4.1.1GHSA-gq7g-vg2q-jvq3

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Syncope 3.0 – through 3.0.164.0 – through 4.0.54.1 – through 4.1.0

Weakness: CWE-653 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

References