Vulnerability · Published Jun 1, 2026 · Assigned by apache
CVE-2026-42588Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Remote Code Execution via Jolokia addNetworkConnector
High 8.1
In plain English
A high-severity improper input validation in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter using the "masterslave:// " URL which can allow loading a Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | activemq | no fix listed | DEBIAN-CVE-2026-42588 |
| Debian:13 | activemq | no fix listed | DEBIAN-CVE-2026-42588 |
| Maven | org.apache.activemq:activemq-all | 5.19.7 | GHSA-hg6c-8mvr-jqc9 |
| Maven | org.apache.activemq:activemq-all | 6.2.6 | GHSA-hg6c-8mvr-jqc9 |
| Maven | org.apache.activemq:activemq-broker | 5.19.7 | GHSA-hg6c-8mvr-jqc9 |
| Maven | org.apache.activemq:activemq-broker | 6.2.6 | GHSA-hg6c-8mvr-jqc9 |
| Maven | org.apache.activemq:apache-activemq | 6.2.6 | GHSA-hg6c-8mvr-jqc9 |
| Maven | org.apache.activemq:apache-activemq | 5.19.7 | GHSA-hg6c-8mvr-jqc9 |
| Ubuntu:24.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-42588 |
| Ubuntu:25.10 | activemq | no fix listed | UBUNTU-CVE-2026-42588 |
| Ubuntu:26.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-42588 |
| Ubuntu:26.10 | activemq | no fix listed | UBUNTU-CVE-2026-42588 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ActiveMQ Broker | 0 – before 5.19.76.0.0 – before 6.2.6 |
| Apache Software Foundation | Apache ActiveMQ All | 0 – before 5.19.76.0.0 – before 6.2.6 |
| Apache Software Foundation | Apache ActiveMQ | 0 – before 5.19.76.0.0 – before 6.2.6 |
Weakness: CWE-20, CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N