Vulnerability · Published May 13, 2026 · Assigned by GitHub_M
CVE-2026-42585Netty: HTTP Request Smuggling due to malformed Transfer-Encoding
Medium 6.5
In plain English
A medium-severity security flaw in netty-codec-http from io.netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.3%top 81.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty incorrectly parses malformed Transfer-Encoding, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | netty | no fix listed | DEBIAN-CVE-2026-42585 |
| Debian:13 | netty | no fix listed | DEBIAN-CVE-2026-42585 |
| Debian:14 | netty | no fix listed | DEBIAN-CVE-2026-42585 |
| Maven | io.netty:netty-codec-http | 4.2.13.Final | GHSA-38f8-5428-x5cv |
| Maven | io.netty:netty-codec-http | 4.1.133.Final | GHSA-38f8-5428-x5cv |
| Ubuntu:25.10 | netty | no fix listed | UBUNTU-CVE-2026-42585 |
| Ubuntu:26.10 | netty | no fix listed | UBUNTU-CVE-2026-42585 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| netty | netty | >= 4.2.0.Alpha1, < 4.2.13.Final< 4.1.133.Final |
| io.netty | netty-codec-http | >= 4.2.0.Alpha1, < 4.2.13.Final< 4.1.133.Final |
Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/netty/netty/security/advisories/GHSA-38f8-5428-x5cv x_refsource_CONFIRM