Vulnerability · Published May 13, 2026 · Assigned by GitHub_M
CVE-2026-42582Netty: HTTP/3 QPACK literal unbounded allocation
High 7.5
In plain English
A high-severity resource allocation without limits in netty-codec-http3 from io.netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final, when decoding header blocks, the non-Huffman branch of io.netty.handler.codec.http3.QpackDecoder#decodeHuffmanEncodedLiteral may execute new byte[length] for a string literal before verifying that length bytes are actually present in the compressed field section. The wire encoding allows a very large length to be expressed in few bytes. There is no check that length <= in.readableBytes() before new byte[length]. This vulnerability is fixed in 4.2.13.Final.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | netty | no fix listed | DEBIAN-CVE-2026-42582 |
| Debian:13 | netty | no fix listed | DEBIAN-CVE-2026-42582 |
| Debian:14 | netty | no fix listed | DEBIAN-CVE-2026-42582 |
| Maven | io.netty:netty-codec-http3 | 4.2.13.Final | GHSA-2c5c-chwr-9hqw |
| Ubuntu:25.10 | netty | no fix listed | UBUNTU-CVE-2026-42582 |
| Ubuntu:26.04:LTS | netty | no fix listed | UBUNTU-CVE-2026-42582 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| netty | netty | >= 4.2.0.Alpha1, < 4.2.13.Final |
| io.netty | netty-codec-http3 | >= 4.2.0.Alpha1, < 4.2.13.Final |
Weakness: CWE-770, CWE-789 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/netty/netty/security/advisories/GHSA-2c5c-chwr-9hqw x_refsource_CONFIRM