Vulnerability · Published May 13, 2026 · Assigned by GitHub_M

CVE-2026-42581Netty: HTTP/1.0 TE+CL Coexistence Bypasses Smuggling Sanitization

Medium 5.8

In plain English

A medium-severity security flaw in netty from netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.8Medium
Exploit odds (30 days)0.6%top 49.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, HttpObjectDecoder strips a conflicting Content-Length header when a request carries both Transfer-Encoding: chunked and Content-Length, but only for HTTP/1.1 messages. The guard is absent for HTTP/1.0. An attacker that sends an HTTP/1.0 request with both headers causes Netty to decode the body as chunked while leaving Content-Length intact in the forwarded HttpMessage. Any downstream proxy or handler that trusts Content-Length over Transfer-Encoding will disagree on message boundaries, enabling request smuggling. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nettyno fix listedDEBIAN-CVE-2026-42581
Debian:13nettyno fix listedDEBIAN-CVE-2026-42581
Debian:14nettyno fix listedDEBIAN-CVE-2026-42581
Mavenio.netty:netty-codec-http4.1.133.FinalGHSA-xxqh-mfjm-7mv9
Mavenio.netty:netty-codec-http4.2.13.FinalGHSA-xxqh-mfjm-7mv9
Ubuntu:25.10nettyno fix listedUBUNTU-CVE-2026-42581
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2026-42581

Affected products (as reported)

VendorProductVersions
netty netty >= 4.2.0.Alpha1, < 4.2.13.Final< 4.1.133.Final

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

References