Vulnerability · Published Jun 9, 2026 · Assigned by GitHub_M

CVE-2026-42573Svelte: XSS via DOM Clobbering of Internal Framework State

High 8.1

In plain English

A high-severity cross-site scripting in svelte from sveltejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.3%top 72.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Svelte is a performance oriented web framework. Prior to version 5.55.7, Svelte was vulnerable to DOM clobbering of its internal framework state on elements, potentially leading to XSS attacks. This issue has been patched in version 5.55.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmsvelte5.55.7GHSA-rcqx-6q8c-2c42

Affected products (as reported)

VendorProductVersions
sveltejs svelte < 5.55.7

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References