Vulnerability · Published Jun 9, 2026 · Assigned by GitHub_M

CVE-2026-42570Svelte devalue: DoS via sparse array deserialization

High 7.5

In plain English

A high-severity resource allocation without limits in devalue from sveltejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 65.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From version 5.6.3 to before version 5.8.1, devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption. This issue has been patched in version 5.8.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmdevalue5.8.1GHSA-77vg-94rm-hx3p

Affected products (as reported)

VendorProductVersions
sveltejs devalue >= 5.6.3, < 5.8.1

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References