Vulnerability · Published May 13, 2026 · Assigned by GitHub_M

CVE-2026-42550Flight: SQL Injection via unvalidated identifiers in SimplePdo::insert / update / delete

High 8.8

In plain English

A high-severity SQL injection in core from flightphp. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.5%top 60.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Flight is an extensible micro-framework for PHP. Prior to 3.18.1, SimplePdo::insert(), SimplePdo::update(), and SimplePdo::delete() build SQL statements by concatenating the $table argument and the keys of the $data array directly into the query, with no identifier quoting and no validation. When an application forwards user-controlled data shapes to these helpers — a common and documented pattern, e.g. $db->insert('users', $request->data->getData()) — an attacker can inject arbitrary SQL by crafting malicious array keys. This vulnerability is fixed in 3.18.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistflightphp/core3.18.1GHSA-xwqr-rcqg-22mr

Affected products (as reported)

VendorProductVersions
flightphp core < 3.18.1

Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References