Vulnerability · Published May 6, 2026 · Assigned by apache
CVE-2026-42509Apache Wicket: crafted strings can break out of the JavaScript sequence
Medium 6.1
In plain English
A medium-severity cross-site scripting in Apache Wicket from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.wicket:wicket-parent | no fix listed | GHSA-5x9h-93gp-chpj |
| Maven | org.apache.wicket:wicket-parent | no fix listed | GHSA-5x9h-93gp-chpj |
| Maven | org.apache.wicket:wicket-parent | 10.9.0 | GHSA-5x9h-93gp-chpj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Wicket | 8.0.0 – through 8.17.09.0.0 – through 9.22.010.0.0 – through 10.8.0 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N