Vulnerability · Published May 8, 2026 · Assigned by GitHub_M
CVE-2026-42451Grimmory: Stored XSS via Malicious EPUB Enables Session Token Theft
Medium 6.3
In plain English
A medium-severity cross-site scripting in grimmory from grimmory-tools. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities).
Official description
Grimmory is a self-hosted digital library. Prior to version 2.3.1, a stored cross-site scripting (XSS) vulnerability in Grimmory's browser-based EPUB reader allows an attacker to embed arbitrary JavaScript in a crafted EPUB file. When a victim opens the book, the script executes in their browser with full access to the Grimmory application's session context. This can enable session token theft and account takeover, including administrative access if an administrator opens the affected book. This issue has been patched in version 2.3.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| grimmory-tools | grimmory | < 2.3.1 |
Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:L
References
- https://github.com/grimmory-tools/grimmory/security/advisories/GHSA-frv6-5wq5-9p24 x_refsource_CONFIRM
- http://github.com/grimmory-tools/grimmory/releases/tag/v2.3.1 x_refsource_MISC