Vulnerability · Published May 8, 2026 · Assigned by GitHub_M

CVE-2026-42354Sentry: Improper authentication on SAML SSO process allows user identity linking

Critical 9.1

In plain English

A critical-severity authentication bypass by spoofing in sentry from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.6%top 49.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Sentry is an error tracking and performance monitoring tool. From version 21.12.0 to before version 26.4.1, a critical vulnerability was discovered in the SAML SSO implementation of Sentry. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. This issue has been patched in version 26.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIsentry26.4.1GHSA-rcmw-7mc7-3rj7
PyPIsentry26.4.1PYSEC-2026-534

Affected products (as reported)

VendorProductVersions
getsentry sentry >= 21.12.0, < 26.4.1

Weakness: CWE-290 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References