Vulnerability · Published May 27, 2026 · Assigned by GitHub_M
CVE-2026-42328go-ipld-prime: DAG-CBOR and DAG-JSON decoders unbounded recursion depth
Medium 6.2
In plain English
A medium-severity security flaw in go-ipld-prime from ipld. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
go-ipld-prime is an implementation of the InterPlanetary Linked Data (IPLD) spec interfaces, a batteries-included codec implementations of IPLD for CBOR and JSON, and tooling for basic operations on IPLD objects. Prior to 0.23.0, the DAG-CBOR and DAG-JSON decoders recurse on each nested map or list without a depth limit. A payload containing deeply nested collections causes the decoder to recurse once per level, growing the goroutine stack until the Go runtime terminates the process with a fatal stack overflow (distinct from a recoverable panic). This vulnerability is fixed in 0.23.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/ipld/go-ipld-prime | 0.23.0 | GO-2026-5684 |
| Go | github.com/ipld/go-ipld-prime | 0.23.0 | GHSA-w239-58x2-q8p5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ipld | go-ipld-prime | < 0.23.0 |
Weakness: CWE-674 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/ipld/go-ipld-prime/security/advisories/GHSA-w239-58x2-q8p5 x_refsource_CONFIRM