Vulnerability · Published May 14, 2026 · Assigned by GitHub_M
CVE-2026-42327rust-openssl: undefined behavior in X509Ref::ocsp_responders for certificates with non-UTF-8 OCSP URLs
High 8.7
In plain English
A high-severity improper input validation in rust-openssl from rust-openssl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.7 to before 0.10.79, X509Ref::ocsp_responders returns OCSP responder URLs from a certificate's AIA extension as OpensslString, whose Deref<Target = str> wraps the raw bytes with str::from_utf8_unchecked. OpenSSL does not enforce that the underlying IA5String is ASCII, so a certificate with non-UTF-8 bytes in its OCSP accessLocation causes safe Rust code to construct a &str that violates the UTF-8 invariant — resulting in undefined behavior. This vulnerability is fixed in 0.10.79.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rust-openssl | no fix listed | DEBIAN-CVE-2026-42327 |
| Debian:13 | rust-openssl | no fix listed | DEBIAN-CVE-2026-42327 |
| Debian:14 | rust-openssl | 0.10.79-1 | DEBIAN-CVE-2026-42327 |
| Ubuntu:25.10 | rust-openssl | no fix listed | UBUNTU-CVE-2026-42327 |
| Ubuntu:26.04:LTS | rust-openssl | no fix listed | UBUNTU-CVE-2026-42327 |
| Ubuntu:26.10 | rust-openssl | no fix listed | UBUNTU-CVE-2026-42327 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rust-openssl | rust-openssl | >= 0.9.7, < 0.10.79 |
Weakness: CWE-20 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N