Vulnerability · Published May 9, 2026 · Assigned by GitHub_M

CVE-2026-42311Pillow: OOB Write with Invalid PSD Tile Extents (Integer Overflow)

High 8.6

In plain English

A high-severity integer overflow in Pillow from python-pillow. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.1%top 95.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Pillow is a Python imaging library. From version 10.3.0 to before version 12.2.0, processing a malicious PSD file could lead to memory corruption, potentially resulting in a crash or arbitrary code execution. This issue has been patched in version 12.2.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13pillow11.1.0-5+deb13u3DEBIAN-CVE-2026-42311
Debian:14pillow12.2.0-1DEBIAN-CVE-2026-42311
PyPIpillow12.2.0GHSA-pwv6-vv43-88gr
PyPIpillow12.2.0PYSEC-2026-2252
Ubuntu:22.04:LTSpillow9.0.1-1ubuntu0.4USN-8399-1
Ubuntu:24.04:LTSpillow10.2.0-1ubuntu1.2USN-8399-1
Ubuntu:25.10pillow11.3.0-1ubuntu1.3USN-8399-1
Ubuntu:25.10pillow11.3.0-1ubuntu1.3UBUNTU-CVE-2026-42311
Ubuntu:26.04:LTSpillow12.1.1-2ubuntu1.2USN-8399-1
Ubuntu:26.04:LTSpillow12.1.1-2ubuntu1.2UBUNTU-CVE-2026-42311

Affected products (as reported)

VendorProductVersions
python-pillow Pillow >= 10.3.0, < 12.2.0

Weakness: CWE-190, CWE-787 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References