Vulnerability · Published Jun 10, 2026 · Assigned by GitHub_M
CVE-2026-42305Dulwich has an arbitrary file write via NTFS-hostile tree entries on Windows
High 8.8
In plain English
A high-severity path traversal in dulwich from jelmer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Dulwich is a pure-Python implementation of the Git file formats and protocols. Versions starting with 0.10.0 and prior to 1.2.5 have an arbitrary file write leading to remote code execution when cloning or checking out a malicious Git repository on Windows. Dulwich's path-element validator accepted tree entries whose filenames contained bytes that Windows interprets as structural path syntax. Contributing configuration bugs made matters worse. The core.protectNTFS and core.protectHFS settings were looked up under a wrong option name and so user-set values were silently ignored, and core.protectNTFS only defaulted to true on Windows (Git upstream has defaulted it to true everywhere since CVE-2019-1353). Both have been corrected. Anyone who clones, fetches, or checks out an untrusted repository with Dulwich on Windows - either through the Dulwich CLI, porcelain.clone, or any downstream tool built on Dulwich - is impacted. POSIX clones are not directly exploitable (on POSIX \ is a literal filename byte), but a POSIX user can unknowingly propagate a malicious tree to Windows consumers via push or re-publication. This issue is fixed in Dulwich 1.2.5. Users should upgrade to 1.2.5 or later. There is no effective pre-patch workaround. On affected versions the core.protectNTFS configuration key was silently ignored, so setting it to true does not mitigate the issue. Users who cannot upgrade should avoid cloning, fetching, or checking out untrusted repositories with Dulwich on Windows. After upgrading the NTFS validator is on by default on every platform, so no additional configuration is required.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | dulwich | no fix listed | DEBIAN-CVE-2026-42305 |
| Debian:13 | dulwich | no fix listed | DEBIAN-CVE-2026-42305 |
| Debian:14 | dulwich | no fix listed | DEBIAN-CVE-2026-42305 |
| PyPI | dulwich | 1.2.5 | GHSA-897w-fcg9-f6xj |
| PyPI | dulwich | 1.2.5 | PYSEC-2026-2463 |
| Ubuntu:22.04:LTS | dulwich | no fix listed | UBUNTU-CVE-2026-42305 |
| Ubuntu:24.04:LTS | dulwich | no fix listed | UBUNTU-CVE-2026-42305 |
| Ubuntu:25.10 | dulwich | no fix listed | UBUNTU-CVE-2026-42305 |
| Ubuntu:26.04:LTS | dulwich | no fix listed | UBUNTU-CVE-2026-42305 |
| Ubuntu:26.10 | dulwich | no fix listed | UBUNTU-CVE-2026-42305 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/jelmer/dulwich/security/advisories/GHSA-897w-fcg9-f6xj x_refsource_CONFIRM
- https://github.com/jelmer/dulwich/commit/49eb56e51aad637fc23d54bf2a08cb42739b8290 x_refsource_MISC
- https://github.com/jelmer/dulwich/commit/57efc4aa1581e038915a0fd79365be53b150f4a9 x_refsource_MISC
- https://github.com/jelmer/dulwich/releases/tag/dulwich-1.2.5 x_refsource_MISC