Vulnerability · Published May 27, 2026 · Assigned by GitHub_M
CVE-2026-42280Improper Permission Checking in Auth.js SDK
High 7.1
In plain English
A high-severity incorrect authorization in auth0.js from auth0. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.2%top 88.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | auth0-js | 10.0.0 | GHSA-8qjv-jj2q-x832 |
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
References
- https://github.com/auth0/auth0.js/security/advisories/GHSA-8qjv-jj2q-x832 x_refsource_CONFIRM