Vulnerability · Published May 12, 2026 · Assigned by GitHub_M

CVE-2026-42268ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators

High 8.2

In plain English

A high-severity security flaw in ModSecurity from owasp-modsecurity. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.4%top 66.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12modsecurity3.0.9-1+deb12u2DEBIAN-CVE-2026-42268
Debian:13modsecurity3.0.14-1+deb13u1DEBIAN-CVE-2026-42268
Debian:14modsecurity3.0.15-1DEBIAN-CVE-2026-42268
Ubuntu:22.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-42268
Ubuntu:24.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-42268
Ubuntu:25.10modsecurityno fix listedUBUNTU-CVE-2026-42268
Ubuntu:26.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-42268
Ubuntu:26.10modsecurityno fix listedUBUNTU-CVE-2026-42268

Affected products (as reported)

VendorProductVersions
owasp-modsecurity ModSecurity >= 3.0.0, < 3.0.15

Weakness: CWE-191, CWE-248 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References