Vulnerability · Published May 4, 2026 · Assigned by GitHub_M
CVE-2026-42238Unauthenticated Remote Code Execution via Backup Restore in nginx-ui
Critical 9.0
In plain English
A critical-severity code injection in nginx-ui from 0xJacky. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.8, nginx-ui exposes a backup restore endpoint (POST /api/restore) that is completely unauthenticated during the first 10 minutes after process startup on any fresh installation. An unauthenticated remote attacker can upload a crafted backup archive that overwrites the application's configuration file (app.ini) and SQLite database. Because the attacker controls the restored app.ini, they can inject an arbitrary OS command into the TestConfigCmd setting. After the application automatically restarts to apply the restored config, a single follow-up request triggers that command as the user running nginx-ui — typically root in Docker deployments. This issue has been patched in version 2.3.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/0xJacky/nginx-ui | 2.3.8 | GHSA-4pvg-prr3-9cxr |
| Go | github.com/0xJacky/nginx-ui | no fix listed | GO-2026-5129 |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-4pvg-prr3-9cxr x_refsource_CONFIRM
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.8 x_refsource_MISC