Vulnerability · Published May 7, 2026 · Assigned by GitHub_M

CVE-2026-42216OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion

High 8.1

In plain English

A high-severity out-of-bounds read in openexr from AcademySoftwareFoundation. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 59.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From versions 3.0.0 to before 3.2.9, 3.3.0 to before 3.3.11, and 3.4.0 to before 3.4.11, IDManifest::init() reconstructs strings from a prefix-compressed representation. If the previous string is longer than 255 bytes, the next string is expected to begin with a 2-byte prefix length. The code reads stringList[i][0] and stringList[i][1] without checking that the current string has at least two bytes. This issue has been patched in versions 3.2.9, 3.3.11, and 3.4.11.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10openexr3.1.10-8.el10_2.3ALSA-2026:38499
AlmaLinux:9openexr3.1.1-3.el9_8.3ALSA-2026:38498
AlmaLinux:10openexr-devel3.1.10-8.el10_2.3ALSA-2026:38499
AlmaLinux:9openexr-devel3.1.1-3.el9_8.3ALSA-2026:38498
AlmaLinux:10openexr-libs3.1.10-8.el10_2.3ALSA-2026:38499
AlmaLinux:9openexr-libs3.1.1-3.el9_8.3ALSA-2026:38498
Alpine:v3.22openexr3.3.11-r0ALPINE-CVE-2026-42216
Alpine:v3.23openexr3.4.13-r0ALPINE-CVE-2026-42216
Alpine:v3.24openexr3.4.11-r0ALPINE-CVE-2026-42216
Debian:12openexrno fix listedDEBIAN-CVE-2026-42216
Debian:13openexrno fix listedDEBIAN-CVE-2026-42216
Debian:14openexr3.4.14-0.1DEBIAN-CVE-2026-42216
Rocky Linux:10openexr0:3.1.10-8.el10_2.3RLSA-2026:38499
Rocky Linux:9openexr0:3.1.1-3.el9_8.3RLSA-2026:38498
Ubuntu:25.10openexrno fix listedUBUNTU-CVE-2026-42216
Ubuntu:26.10openexrno fix listedUBUNTU-CVE-2026-42216

Affected products (as reported)

VendorProductVersions
AcademySoftwareFoundation openexr >= 3.0.0, < 3.2.9>= 3.3.0, < 3.3.11>= 3.4.0, < 3.4.11

Weakness: CWE-125, CWE-130 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

References