Vulnerability · Published May 4, 2026 · Assigned by GitHub_M
CVE-2026-42052beets is Vulnerable to XSS
Medium 6.0
In plain English
A medium-severity cross-site scripting in beets from beetbox. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Beets is the media library management system. Prior to version 2.10.0, the bundled web UI uses Underscore template interpolation mode <%= ... %> for untrusted metadata fields. In this runtime, <%= ... %> is raw insertion and HTML escaping is only performed by <%- ... %>. Rendered output is then inserted with .html(...), allowing attacker-controlled markup to become active DOM. This issue has been patched in version 2.10.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | beets | 1.6.0-4+deb12u1 | DEBIAN-CVE-2026-42052 |
| Debian:13 | beets | 2.2.0-3+deb13u1 | DEBIAN-CVE-2026-42052 |
| Debian:14 | beets | 2.11.0-1 | DEBIAN-CVE-2026-42052 |
| PyPI | beets | 2.10.0 | GHSA-3gxm-wfjx-m847 |
| PyPI | beets | 2.10.0 | PYSEC-2026-2397 |
| Ubuntu:25.10 | beets | no fix listed | UBUNTU-CVE-2026-42052 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N