Vulnerability · Published May 12, 2026 · Assigned by GitHub_M
CVE-2026-42048Langflow: Path Traversal in Langflow Knowledge Bases API
Critical 9.6
In plain English
A critical-severity path traversal in langflow from langflow-ai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 4.2% (higher than 91% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.9.0, Langflow is vulnerable to Path Traversal in the Knowledge Bases API (DELETE /api/v1/knowledge_bases). This occurs because user-supplied knowledge base names are concatenated directly into file paths without proper sanitization or boundary validation. An authenticated attacker can exploit this flaw to delete arbitrary directories anywhere on the server's filesystem, leading to data loss and potential service disruption. This vulnerability is fixed in 1.9.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | langflow | 1.9.0 | GHSA-9whx-c884-c68q |
| PyPI | langflow | 1.9.0 | PYSEC-2026-377 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| langflow-ai | langflow | < 1.9.0 |
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H
References
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-9whx-c884-c68q x_refsource_CONFIRM