Vulnerability · Published May 7, 2026 · Assigned by GitHub_M
CVE-2026-42047Inngest TypeScript SDK exposes environment variables via serve() handler on unhandled HTTP methods
High 8.6
In plain English
A high-severity information exposure in inngest-js from inngest. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Inngest is a platform for running event-driven and scheduled background functions with queueing, retries, and step orchestration. Versions 3.22.0 through 3.53.1 contain a vulnerability that allows unauthenticated remote attackers to exfiltrate environment variables from the host process via the serve() HTTP handler. The serve() handler implements GET, POST, and PUT methods. Requests using PATCH, OPTIONS, or DELETE fall through to a generic handler that returns diagnostic information. A change introduced in v3.22.0 caused this diagnostic response to include the contents of process.env, exposing any secrets, API keys, or credentials present in the environment. An application is vulnerable if its serve() endpoint is reachable via PATCH, OPTIONS, or DELETE requests, which is common in setups like Next.js Pages Router or Express's app.use(...). Not affected are Next.js App Router handlers that export only GET, POST, and PUT, and applications using the connect worker method. This issue has been fixed in version 3.54.0. To work around this issue if upgrading is not immediately possible, restrict the serve() endpoint at the framework or reverse-proxy layer to accept only GET, POST, and PUT. The Inngest serve() endpoint does not require any other HTTP methods.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | inngest | 3.54.0 | GHSA-2jf5-6wwv-vhxx |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| inngest | inngest-js | >= 3.22.0, < 3.54.0 |
Weakness: CWE-200, CWE-497 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
References
- https://github.com/inngest/inngest-js/security/advisories/GHSA-2jf5-6wwv-vhxx x_refsource_CONFIRM
- https://github.com/inngest/inngest-js/releases/tag/inngest%403.54.1 x_refsource_MISC