Vulnerability · Published May 8, 2026 · Assigned by GitHub_M
CVE-2026-42030MapServer: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in OpenLayers viewer
Medium 6.1
In plain English
A medium-severity security flaw in MapServer from MapServer. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
MapServer is a system for developing web-based GIS applications. From version 6.0 to before version 8.6.2, a reflected XSS vulnerability in MapServer's WMS server allows an unauthenticated attacker to inject arbitrary HTML/JavaScript into the browser of any user who opens a crafted WMS URL. The vulnerability is triggered via FORMAT=application/openlayers combined with an unsanitized SRS parameter in WMS 1.3.0 requests. This issue has been patched in version 8.6.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | mapserver | no fix listed | DEBIAN-CVE-2026-42030 |
| Debian:13 | mapserver | no fix listed | DEBIAN-CVE-2026-42030 |
| Debian:14 | mapserver | 8.6.2-1 | DEBIAN-CVE-2026-42030 |
| Ubuntu:22.04:LTS | mapserver | no fix listed | UBUNTU-CVE-2026-42030 |
| Ubuntu:24.04:LTS | mapserver | no fix listed | UBUNTU-CVE-2026-42030 |
| Ubuntu:25.10 | mapserver | no fix listed | UBUNTU-CVE-2026-42030 |
| Ubuntu:26.04:LTS | mapserver | no fix listed | UBUNTU-CVE-2026-42030 |
| Ubuntu:26.10 | mapserver | no fix listed | UBUNTU-CVE-2026-42030 |
Affected products (as reported)
Weakness: CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/MapServer/MapServer/security/advisories/GHSA-4g9f-ph64-hg2x x_refsource_CONFIRM
- https://github.com/MapServer/MapServer/releases/tag/rel-8-6-2 x_refsource_MISC