Vulnerability · Published Sep 9, 2026 · Assigned by apache

CVE-2026-41869Apache Nutch: Unauthenticated forced shutdown and job interruption in Nutch Server (Nutch REST API)

Critical 9.1

In plain English

A critical-severity missing authorization in Apache Nutch from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities).

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.7%top 45.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Missing Authorization, Improper Resource Shutdown and Job Interruption vulnerability in Apache Nutch Server (Nutch REST API). This issue affects Apache Nutch: from 1.10 through 1.22. Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Nutch 1.10 – through 1.22

Weakness: CWE-862, CWE-404 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

References