Vulnerability · Published Mar 29, 2026 · Assigned by CPANSec

CVE-2026-4176Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib

Critical 9.8

In plain English

A critical-severity security flaw in perl from SHAY. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)0.7%top 45.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib. Compress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24perl5.42.2-r0ALPINE-CVE-2026-4176
Debian:12perl5.10.0-21DEBIAN-CVE-2026-4176
Debian:13perl5.10.0-21DEBIAN-CVE-2026-4176
Debian:14perl5.10.0-21DEBIAN-CVE-2026-4176

Affected products (as reported)

VendorProductVersions
SHAY perl 5.9.4 – before 5.40.4-RC15.41.0 – before 5.42.2-RC15.43.0 – before 5.43.9

Weakness: CWE-1395 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References