Vulnerability · Published Apr 24, 2026 · Assigned by GitHub_M

CVE-2026-41678rust-openssl: Incorrect bounds assertion in aes key wrap

High 7.2

In plain English

A high-severity out-of-bounds write in rust-openssl from rust-openssl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.2High
Exploit odds (30 days)0.3%top 83.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

rust-openssl provides OpenSSL bindings for the Rust programming language. From to before 0.10.78, aes::unwrap_key() contains an incorrect assertion: it checks that out.len() + 8 <= in_.len(), but this condition is reversed. The intended invariant is out.len() >= in_.len() - 8, ensuring the output buffer is large enough. Because of the inverted check, the function only accepts buffers at or below the minimum required size and rejects larger ones. If a smaller buffer is provided the function will write past the end of out by in_.len() - 8 - out.len() bytes, causing an out-of-bounds write from a safe public function. This vulnerability is fixed in 0.10.78.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rust-opensslno fix listedDEBIAN-CVE-2026-41678
Debian:13rust-opensslno fix listedDEBIAN-CVE-2026-41678
Debian:14rust-openssl0.10.78-1DEBIAN-CVE-2026-41678
Ubuntu:25.10rust-opensslno fix listedUBUNTU-CVE-2026-41678
Ubuntu:26.04:LTSrust-opensslno fix listedUBUNTU-CVE-2026-41678
Ubuntu:26.10rust-opensslno fix listedUBUNTU-CVE-2026-41678

Affected products (as reported)

VendorProductVersions
rust-openssl rust-openssl >= 0.10.24, < 0.10.78

Weakness: CWE-787 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

References