Vulnerability · Published Apr 22, 2026 · Assigned by GitHub_M

CVE-2026-41651PackageKit vulnerable to TOCTOU Race on Transaction Flags leads to arbitrary package installation as root

High 8.8

In plain English

A high-severity security flaw in PackageKit from PackageKit. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.5%top 60.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

PackageKit is a a D-Bus abstraction layer that allows the user to manage packages in a secure way using a cross-distro, cross-architecture API. PackageKit between and including versions 1.0.2 and 1.3.4 is vulnerable to a time-of-check time-of-use (TOCTOU) race condition on transaction flags that allows unprivileged users to install packages as root and thus leads to a local privilege escalation. This is patched in version 1.3.5. A local unprivileged user can install arbitrary RPM packages as root, including executing RPM scriptlets, without authentication. The vulnerability is a TOCTOU race condition on `transaction->cached_transaction_flags` combined with a silent state-machine guard that discards illegal backward transitions while leaving corrupted flags in place. Three bugs exist in `src/pk-transaction.c`: 1. Unconditional flag overwrite (line 4036): `InstallFiles()` writes caller-supplied flags to `transaction->cached_transaction_flags` without checking whether the transaction has already been authorized/started. A second call blindly overwrites the flags even while the transaction is RUNNING. 2. Silent state-transition rejection (lines 873–882): `pk_transaction_set_state()` silently discards backward state transitions (e.g. `RUNNING` → `WAITING_FOR_AUTH`) but the flag overwrite at step 1 already happened. The transaction continues running with corrupted flags. 3. Late flag read at execution time (lines 2273–2277): The scheduler's idle callback reads cached_transaction_flags at dispatch time, not at authorization time. If flags were overwritten between authorization and execution, the backend sees the attacker's flags.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10PackageKit1.2.8-8.el10_2ALSA-2026:19141
AlmaLinux:8PackageKit1.1.12-8.el8_10ALSA-2026:11635
AlmaLinux:9PackageKit1.2.6-2.el9_8ALSA-2026:19354
AlmaLinux:9PackageKit1.2.6-2.el9_7ALSA-2026:11504
AlmaLinux:10PackageKit-command-not-found1.2.8-8.el10_2ALSA-2026:19141
AlmaLinux:8PackageKit-command-not-found1.1.12-8.el8_10ALSA-2026:11635
AlmaLinux:9PackageKit-command-not-found1.2.6-2.el9_8ALSA-2026:19354
AlmaLinux:9PackageKit-command-not-found1.2.6-2.el9_7ALSA-2026:11504
AlmaLinux:8PackageKit-cron1.1.12-8.el8_10ALSA-2026:11635
AlmaLinux:10PackageKit-glib1.2.8-8.el10_2ALSA-2026:19141
AlmaLinux:8PackageKit-glib1.1.12-8.el8_10ALSA-2026:11635
AlmaLinux:9PackageKit-glib1.2.6-2.el9_8ALSA-2026:19354
AlmaLinux:9PackageKit-glib1.2.6-2.el9_7ALSA-2026:11504
AlmaLinux:10PackageKit-glib-devel1.2.8-8.el10_2ALSA-2026:19141
AlmaLinux:8PackageKit-glib-devel1.1.12-8.el8_10ALSA-2026:11635
AlmaLinux:9PackageKit-glib-devel1.2.6-2.el9_8ALSA-2026:19354
AlmaLinux:9PackageKit-glib-devel1.2.6-2.el9_7ALSA-2026:11504
AlmaLinux:10PackageKit-gstreamer-plugin1.2.8-8.el10_2ALSA-2026:19141
AlmaLinux:8PackageKit-gstreamer-plugin1.1.12-8.el8_10ALSA-2026:11635
AlmaLinux:9PackageKit-gstreamer-plugin1.2.6-2.el9_8ALSA-2026:19354
AlmaLinux:9PackageKit-gstreamer-plugin1.2.6-2.el9_7ALSA-2026:11504
AlmaLinux:10PackageKit-gtk3-module1.2.8-8.el10_2ALSA-2026:19141
AlmaLinux:8PackageKit-gtk3-module1.1.12-8.el8_10ALSA-2026:11635
AlmaLinux:9PackageKit-gtk3-module1.2.6-2.el9_7ALSA-2026:11504
AlmaLinux:9PackageKit-gtk3-module1.2.6-2.el9_8ALSA-2026:19354
Debian:12packagekit1.2.6-5+deb12u1DEBIAN-CVE-2026-41651
Debian:13packagekit1.3.1-1+deb13u1DEBIAN-CVE-2026-41651
Debian:14packagekit1.3.5-1DEBIAN-CVE-2026-41651
Rocky Linux:10PackageKit0:1.2.8-8.el10RLSA-2026:19141
Rocky Linux:8PackageKit0:1.1.12-8.el8_10RLSA-2026:11635
Rocky Linux:9PackageKit0:1.2.6-2.el9_7RLSA-2026:11504
Rocky Linux:9PackageKit0:1.2.6-2.el9_7RLSA-2026:19354
Ubuntu:22.04:LTSpackagekit1.2.5-2ubuntu3.1UBUNTU-CVE-2026-41651
Ubuntu:24.04:LTSpackagekit1.2.8-2ubuntu1.5UBUNTU-CVE-2026-41651
Ubuntu:25.10packagekit1.3.1-1ubuntu1.1UBUNTU-CVE-2026-41651
Ubuntu:26.04:LTSpackagekit1.3.4-3ubuntu1UBUNTU-CVE-2026-41651

Affected products (as reported)

VendorProductVersions
PackageKit PackageKit >= 1.0.2, <= 1.3.4

Weakness: CWE-367 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References