Vulnerability · Published May 7, 2026 · Assigned by GitHub_M
CVE-2026-41643GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE
High 7.5
In plain English
A high-severity security flaw in gobgp from osrg. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | gobgp | no fix listed | DEBIAN-CVE-2026-41643 |
| Debian:13 | gobgp | no fix listed | DEBIAN-CVE-2026-41643 |
| Debian:14 | gobgp | 4.3.0-1 | DEBIAN-CVE-2026-41643 |
| Go | github.com/osrg/gobgp/v4 | 4.3.0 | GHSA-8rxh-r2p6-7f2q |
| Go | github.com/osrg/gobgp/v4 | 4.3.0 | GO-2026-5266 |
| Ubuntu:25.10 | gobgp | no fix listed | UBUNTU-CVE-2026-41643 |
Affected products (as reported)
Weakness: CWE-129 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/osrg/gobgp/security/advisories/GHSA-8rxh-r2p6-7f2q x_refsource_CONFIRM
- https://github.com/osrg/gobgp/releases/tag/v4.3.0 x_refsource_MISC