Vulnerability · Published Apr 28, 2026 · Assigned by apache
CVE-2026-41636Apache Thrift: Node.js skip() recursion
High 8.7
In plain English
A high-severity security flaw in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 60.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.24 | thrift | 0.23.0-r0 | ALPINE-CVE-2026-41636 |
| Debian:12 | thrift | no fix listed | DEBIAN-CVE-2026-41636 |
| Debian:13 | thrift | no fix listed | DEBIAN-CVE-2026-41636 |
| Debian:14 | thrift | 0.23.0-3 | DEBIAN-CVE-2026-41636 |
| Ubuntu:22.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-41636 |
| Ubuntu:24.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-41636 |
| Ubuntu:25.10 | thrift | no fix listed | UBUNTU-CVE-2026-41636 |
| Ubuntu:26.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-41636 |
| Ubuntu:26.10 | thrift | no fix listed | UBUNTU-CVE-2026-41636 |
| npm | thrift | 0.23.0 | GHSA-r67j-r569-jrwp |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Thrift | 0 – before 0.23.0 |
Weakness: CWE-674 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L