Vulnerability · Published Apr 28, 2026 · Assigned by apache

CVE-2026-41606Apache Thrift: c_glib dispatch stack overflow

Medium 5.3

In plain English

A medium-severity security flaw in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.1%top 34.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Uncontrolled Recursion vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24thrift0.23.0-r0ALPINE-CVE-2026-41606
Debian:12thriftno fix listedDEBIAN-CVE-2026-41606
Debian:13thriftno fix listedDEBIAN-CVE-2026-41606
Debian:14thrift0.23.0-3DEBIAN-CVE-2026-41606
Ubuntu:22.04:LTSthriftno fix listedUBUNTU-CVE-2026-41606
Ubuntu:24.04:LTSthriftno fix listedUBUNTU-CVE-2026-41606
Ubuntu:25.10thriftno fix listedUBUNTU-CVE-2026-41606
Ubuntu:26.04:LTSthriftno fix listedUBUNTU-CVE-2026-41606
Ubuntu:26.10thriftno fix listedUBUNTU-CVE-2026-41606

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Thrift 0 – before 0.23.0

Weakness: CWE-674, CWE-606 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References