Vulnerability · Published May 8, 2026 · Assigned by GitHub_M
CVE-2026-41575th30d4y/IP: DOM-Based Cross-Site Scripting (XSS) Vulnerability
Medium 6.1
In plain English
A medium-severity cross-site scripting in IP from th30d4y. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.
Official description
In th30d4y/IP from version 1.0.1 to before version 2.0.1, a DOM-Based Cross-Site Scripting (XSS) vulnerability was identified in an IP Reputation Checker application. Unsanitized user input was directly rendered in the browser, allowing attackers to execute arbitrary JavaScript. This issue has been patched in version 2.0.1.
Affected products (as reported)
Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/th30d4y/IP/security/advisories/GHSA-j7wv-7j97-9qh9 x_refsource_CONFIRM