Vulnerability · Published May 7, 2026 · Assigned by GitHub_M
CVE-2026-41490Dagster Vulnerable to SQL Injection via Dynamic Partition Keys in Database I/O Manager Integrations
High 8.3
In plain English
A high-severity SQL injection in dagster from dagster-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Dagster is an orchestration platform for the development, production, and observation of data assets. Prior to Dagster Core version 1.13.1 and prior to Dagster libraries version 0.29.1, the DuckDB, Snowflake, BigQuery, and DeltaLake I/O managers constructed SQL WHERE clauses by interpolating dynamic partition key values into queries without escaping. A user with the Add Dynamic Partitions permission could create a partition key that injects arbitrary SQL, which would execute against the target database backend under the I/O manager's credentials. Only deployments that use dynamic partitions are affected. Pipelines using static or time-window partitions are not impacted. This issue has been patched in Dagster Core version 1.13.1 and Dagster libraries version 0.29.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | dagster | 1.13.1 | PYSEC-2026-2432 |
| PyPI | dagster | 1.13.1 | GHSA-mjw2-v2hm-wj34 |
| PyPI | dagster-deltalake | 0.29.1 | GHSA-mjw2-v2hm-wj34 |
| PyPI | dagster-deltalake | 0.29.1 | PYSEC-2026-2433 |
| PyPI | dagster-duckdb | 0.29.1 | PYSEC-2026-2434 |
| PyPI | dagster-duckdb | 0.29.1 | GHSA-mjw2-v2hm-wj34 |
| PyPI | dagster-gcp | 0.29.1 | PYSEC-2026-2435 |
| PyPI | dagster-gcp | 0.29.1 | GHSA-mjw2-v2hm-wj34 |
| PyPI | dagster-snowflake | 0.29.1 | GHSA-mjw2-v2hm-wj34 |
| PyPI | dagster-snowflake | 0.29.1 | PYSEC-2026-2436 |
| PyPI | dagster-snowflake-polars | 0.29.1 | PYSEC-2026-2437 |
| PyPI | dagster-snowflake-polars | 0.29.1 | GHSA-mjw2-v2hm-wj34 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| dagster-io | dagster | dagster < 1.13.1dagster-duckdb < 0.29.1dagster-snowflake < 0.29.1dagster-gcp < 0.29.1dagster-deltalake < 0.29.1dagster-snowflake-polars < 0.29.1 |
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
References
- https://github.com/dagster-io/dagster/security/advisories/GHSA-mjw2-v2hm-wj34 x_refsource_CONFIRM
- https://github.com/dagster-io/dagster/releases/tag/1.13.1 x_refsource_MISC