Vulnerability · Published Apr 24, 2026 · Assigned by GitHub_M
CVE-2026-41427Better Auth OAuth 2.1 Provider: Unprivileged users can register OAuth clients
High 7.1
In plain English
A high-severity incorrect authorization in better-auth from better-auth. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Better Auth is an authentication and authorization library for TypeScript. Prior to 1.6.5, the clientPrivileges option documents a create action, but the OAuth client creation endpoints did not invoke the hook before persisting new clients. Deployments that configured clientPrivileges to restrict client registration were not actually restricted — any authenticated user could reach the create endpoints and register an OAuth client with attacker-chosen redirect URIs and metadata. This vulnerability is fixed in 1.6.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @better-auth/oauth-provider | 1.6.5 | GHSA-xr8f-h2gw-9xh6 |
| npm | @better-auth/oauth-provider | no fix listed | GHSA-xr8f-h2gw-9xh6 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| better-auth | better-auth | >= 1.4.8-beta.7, < 1.6.5>= 1.7.0-beta.0, <= 1.7.0-beta.1 |
| better-auth | oauth-provider | >= 1.4.8-beta.7, < 1.6.5>= 1.7.0-beta.0, <= 1.7.0-beta.1 |
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:L/SA:N