Vulnerability · Published May 8, 2026 · Assigned by GitHub_M

CVE-2026-41423Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server

High 8.7

In plain English

A high-severity server-side request forgery in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.3%top 76.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8, a Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server due to improper handling of URLs during Server-Side Rendering (SSR). When an attacker sends a request such as GET /\evil.com/ HTTP/1.1 the server engine (Express, etc.) passes the URL string to Angular’s rendering functions. Because the URL parser normalizes the backslash to a forward slash for HTTP/HTTPS schemes, the internal state of the application is hijacked to believe the current origin is evil.com. This misinterpretation tricks the application into treating the attacker’s domain as the local origin. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. This issue has been patched in versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-41423
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-41423
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-41423
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-41423
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-41423
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-41423
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-41423
npm@angular/platform-serverno fix listedGHSA-45q2-gjvg-7973
npm@angular/platform-server19.2.21GHSA-45q2-gjvg-7973
npm@angular/platform-server20.3.19GHSA-45q2-gjvg-7973
npm@angular/platform-server21.2.9GHSA-45q2-gjvg-7973
npm@angular/platform-server22.0.0-next.8GHSA-45q2-gjvg-7973

Affected products (as reported)

VendorProductVersions
angular angular < 19.2.21>= 20.0.0-next.0, < 20.3.19>= 21.0.0-next.0, < 21.2.9>= 22.0.0-next.0, < 22.0.0-next.8

Weakness: CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N

References