Vulnerability · Published May 6, 2026 · Assigned by GitHub_M

CVE-2026-41417Netty vulnerable to HTTP request smuggling and RTSP request injection via DefaultHttpRequest.setUri()

Medium 5.3

In plain English

A medium-severity security flaw in netty from netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.3%top 75.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Netty allows request-line validation to be bypassed when a `DefaultHttpRequest` or `DefaultFullHttpRequest` is created first and its URI is later changed via `setUri()`. The constructors reject CRLF and whitespace characters that would break the start-line, but `setUri()` does not apply the same validation. `HttpRequestEncoder` and `RtspEncoder` then write the URI into the request line verbatim. If attacker-controlled input reaches `setUri()`, this enables CRLF injection and insertion of additional HTTP or RTSP requests, leading to HTTP request smuggling or desynchronization on the HTTP side and request injection on the RTSP side. This issue is fixed in versions 4.2.13.Final and 4.1.133.Final.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nettyno fix listedDEBIAN-CVE-2026-41417
Debian:13nettyno fix listedDEBIAN-CVE-2026-41417
Debian:14nettyno fix listedDEBIAN-CVE-2026-41417
Mavenio.netty:netty-codec-http4.2.13.FinalGHSA-v8h7-rr48-vmmv
Mavenio.netty:netty-codec-http4.1.133.FinalGHSA-v8h7-rr48-vmmv
Ubuntu:25.10nettyno fix listedUBUNTU-CVE-2026-41417
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2026-41417

Affected products (as reported)

VendorProductVersions
netty netty >= 4.2.0.Alpha1, <= 4.2.12.Final<= 4.1.132.Final

Weakness: CWE-93, CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References