Vulnerability · Published Apr 24, 2026 · Assigned by GitHub_M
CVE-2026-41415PJSIP: SIP Multipart CID URI Length Underflow
Medium 6.7
In plain English
A medium-severity out-of-bounds read in pjproject from pjsip. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an out-of-bounds read when parsing a malformed Content-ID URI in SIP multipart message body. Insufficient length validation can cause reads beyond the intended buffer bounds. This vulnerability is fixed in 2.17.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | asterisk | 1:22.10.0+dfsg+~cs6.17.60671434-1 | DEBIAN-CVE-2026-41415 |
| Ubuntu:22.04:LTS | asterisk | no fix listed | UBUNTU-CVE-2026-41415 |
| Ubuntu:24.04:LTS | asterisk | no fix listed | UBUNTU-CVE-2026-41415 |
| Ubuntu:25.10 | asterisk | no fix listed | UBUNTU-CVE-2026-41415 |
| Ubuntu:26.04:LTS | asterisk | no fix listed | UBUNTU-CVE-2026-41415 |
| Ubuntu:26.10 | asterisk | no fix listed | UBUNTU-CVE-2026-41415 |
Affected products (as reported)
Weakness: CWE-125 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U