Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41276Flowise: AccountService resetPassword Authentication Bypass Vulnerability
High 7.7
In plain English
A high-severity improper authentication in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 6.9% (higher than 94% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, this vulnerability allows remote attackers to bypass authentication on affected installations of FlowiseAI Flowise. Authentication is not required to exploit this vulnerability. The specific flaw exists within the resetPassword method of the AccountService class. There is no check performed to ensure that a password reset token has actually been generated for a user account. By default the value of the reset token stored in a users account is null, or an empty string if they've reset their password before. An attacker with knowledge of the user's email address can submit a request to the "/api/v1/account/reset-password" endpoint containing a null or empty string reset token value and reset that user's password to a value of their choosing. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-f6hc-c5jr-878p |
Affected products (as reported)
Weakness: CWE-287 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-f6hc-c5jr-878p x_refsource_CONFIRM