Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41274Flowise: Cypher Injection in GraphCypherQAChain
Critical 9.3
In plain English
A critical-severity security flaw in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the GraphCypherQAChain node forwards user-provided input directly into the Cypher query execution pipeline without proper sanitization. An attacker can inject arbitrary Cypher commands that are executed on the underlying Neo4j database, enabling data exfiltration, modification, or deletion. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-28g4-38q8-3cwc |
| npm | flowise-components | 3.1.0 | GHSA-28g4-38q8-3cwc |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FlowiseAI | Flowise | < 3.1.0 |
| FlowiseAI | flowise-components | < 3.1.0 |
Weakness: CWE-943 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-28g4-38q8-3cwc x_refsource_CONFIRM