Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M

CVE-2026-41268Flowise: Flowise Parameter Override Bypass Remote Command Execution

High 7.7

In plain English

A high-severity improper input validation in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 17.4% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)7.7High
Exploit odds (30 days)17.4%top 2.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmflowise3.1.0GHSA-cvrr-qhgw-2mm6
npmflowise-components3.1.0GHSA-cvrr-qhgw-2mm6

Affected products (as reported)

VendorProductVersions
FlowiseAI Flowise < 3.1.0

Weakness: CWE-20 · Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

References