Vulnerability · Published Apr 22, 2026 · Assigned by GitHub_M
CVE-2026-41175Statamic: Unsafe method invocation via query value resolution allows data destruction
High 8.1
In plain English
A high-severity security flaw in cms from statamic. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Statamic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.20 and 6.13.0, manipulating query parameters on Control Panel and REST API endpoints, or arguments in GraphQL queries, could result in the loss of content, assets, and user accounts. The Control Panel requires authentication with minimal permissions in order to exploit. e.g. "view entries" permission to delete entries, or "view users" permission to delete users, etc. The REST and GraphQL API exploits do not require any permissions, however neither are enabled by default. In order to be exploited, they would need to be explicitly enabled with no authentication configured, and the specific resources enabled too. Sites that enable the REST or GraphQL API without authentication should treat patching as critical priority. This has been fixed in 5.73.20 and 6.13.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | statamic/cms | 5.73.20 | GHSA-4jjr-vmv7-wh4w |
| Packagist | statamic/cms | 6.13.0 | GHSA-4jjr-vmv7-wh4w |
Affected products (as reported)
Weakness: CWE-470 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
References
- https://github.com/statamic/cms/security/advisories/GHSA-4jjr-vmv7-wh4w x_refsource_CONFIRM