Vulnerability · Published Apr 22, 2026 · Assigned by GitHub_M

CVE-2026-41168pypdf has possible long runtimes for wrong size values in cross-reference and object streams

Medium 6.9

In plain English

A medium-severity security flaw in pypdf from py-pdf. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.3%top 77.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

pypdf is a free and open-source pure-python PDF library. An attacker who uses a vulnerability present in versions prior to 6.10.1 can craft a PDF which leads to long runtimes. This requires cross-reference streams with wrong large `/Size` values or object streams with wrong large `/N` values. This has been fixed in pypdf 6.10.1. As a workaround, one may apply the changes from the patch manually.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12pypdfno fix listedDEBIAN-CVE-2026-41168
Debian:13pypdfno fix listedDEBIAN-CVE-2026-41168
Debian:14pypdf6.19.0-1DEBIAN-CVE-2026-41168
Debian:12pypdf2no fix listedDEBIAN-CVE-2026-41168
PyPIpypdf6.10.1GHSA-jj6c-8h6c-hppx
PyPIpypdf6.10.1PYSEC-2026-3021
Ubuntu:24.04:LTSpypdfno fix listedUBUNTU-CVE-2026-41168
Ubuntu:25.10pypdfno fix listedUBUNTU-CVE-2026-41168
Ubuntu:26.04:LTSpypdfno fix listedUBUNTU-CVE-2026-41168
Ubuntu:26.10pypdfno fix listedUBUNTU-CVE-2026-41168
Ubuntu:22.04:LTSpypdf2no fix listedUBUNTU-CVE-2026-41168
Ubuntu:24.04:LTSpypdf2no fix listedUBUNTU-CVE-2026-41168

Affected products (as reported)

VendorProductVersions
py-pdf pypdf < 6.10.1

Weakness: CWE-834 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

References