Vulnerability · Published May 29, 2026 · Assigned by GitHub_M

CVE-2026-41159Mermaid: Improper sanitization of configuration leads to CSS injection

Medium 5.3

In plain English

A medium-severity code injection in mermaid from mermaid-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.5%top 57.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.6 and 11.15.0, Mermaid's default configuration allows injecting CSS that applies outside of the Mermaid diagram via the fontFamily, themeCSS, and altFontFamily configuration options. The injected CSS exploits stylis's & (scope reference) handling. :not(&) escapes the #mermaid-xxx automatic scoping, applying styles to all page elements. Global at-rules (@font-face, @keyframes, @counter-style) are also injectable as stylis hoists them to top level. This allows page defacement and DOM attribute exfiltration via CSS :has() selectors. This vulnerability is fixed in 10.9.6 and 11.15.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14node-mermaidno fix listedDEBIAN-CVE-2026-41159
Ubuntu:22.04:LTSnode-mermaidno fix listedUBUNTU-CVE-2026-41159
Ubuntu:26.10node-mermaidno fix listedUBUNTU-CVE-2026-41159
npmmermaid11.15.0GHSA-87f9-hvmw-gh4p
npmmermaid10.9.6GHSA-87f9-hvmw-gh4p

Affected products (as reported)

VendorProductVersions
mermaid-js mermaid >= 11.0.0-alpha.1, < 11.15.0< 10.9.6

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L

References