Vulnerability · Published May 22, 2026 · Assigned by GitHub_M

CVE-2026-41148Mermaid: Improper sanitization of `classDefs` in diagrams leads to CSS injection

Medium 5.3

In plain English

A medium-severity code injection in mermaid from mermaid-js. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.3%top 72.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Versions 10.9.5 and prior, in addition to 11.0.0-alpha.1 through 11.12.0 are vulnerable to CSS injection through improper sanitization. The state diagram (and any other diagram type that routes user-controlled style strings through the createCssStyles parser) captures classDef values using an unrestricted regex that matches everything up to a newline. That value then flows unsanitized through addStyleClass() into createCssStyles() and is assigned to style.innerHTML, so a closing brace (}) in the value terminates the generated CSS selector and turns everything after it into a new CSS rule on the page. This enables page defacement, user tracking via url() callbacks, and DOM attribute exfiltration. This issue has been fixed in versions 10.9.6 and 11.15.0. If developers are unable to immediately upgrade, they can work around this issue by setting "securityLevel": "sandbox", which prevents the issue by rendering the mermaid diagram in a sandboxed <iframe>.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14node-mermaidno fix listedDEBIAN-CVE-2026-41148
Ubuntu:22.04:LTSnode-mermaidno fix listedUBUNTU-CVE-2026-41148
Ubuntu:26.10node-mermaidno fix listedUBUNTU-CVE-2026-41148
npmmermaid11.15.0GHSA-xcj9-5m2h-648r
npmmermaid10.9.6GHSA-xcj9-5m2h-648r

Affected products (as reported)

VendorProductVersions
mermaid-js mermaid >= 11.0.0-alpha.1, < 11.15.0< 10.9.6

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L

References