Vulnerability · Published Apr 24, 2026 · Assigned by GitHub_M

CVE-2026-41140Poetry: Path traversal in tar extraction on Python 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4

High 8.7

In plain English

A high-severity path traversal in poetry from python-poetry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.7High
Exploit odds (30 days)0.3%top 77.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12poetryno fix listedDEBIAN-CVE-2026-41140
Debian:13poetry2.1.2+dfsg-1DEBIAN-CVE-2026-41140
Debian:14poetry2.1.2+dfsg-1DEBIAN-CVE-2026-41140
PyPIpoetry2.3.4GHSA-73h3-mf4w-8647
PyPIpoetry2.3.4PYSEC-2026-2890
Ubuntu:22.04:LTSpoetryno fix listedUBUNTU-CVE-2026-41140
Ubuntu:24.04:LTSpoetryno fix listedUBUNTU-CVE-2026-41140
Ubuntu:25.10poetryno fix listedUBUNTU-CVE-2026-41140
Ubuntu:26.04:LTSpoetryno fix listedUBUNTU-CVE-2026-41140
Ubuntu:26.10poetryno fix listedUBUNTU-CVE-2026-41140

Affected products (as reported)

VendorProductVersions
python-poetry poetry < 2.3.4

Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:H

References