Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41138Flowise: Remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas.
High 8.3
In plain English
A high-severity code injection in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, there is a remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas. The user’s input is directly applied to the question parameter within the prompt template and it is reflected to the Python code without any sanitization. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-f228-chmx-v6j6 |
| npm | flowise-components | 3.1.0 | GHSA-f228-chmx-v6j6 |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-f228-chmx-v6j6 x_refsource_CONFIRM