Vulnerability · Published Apr 27, 2026 · Assigned by vmware
CVE-2026-40976
Critical 9.1
In plain English
A critical-severity missing authorization in Spring Boot from Spring. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.springframework.boot:spring-boot | 4.0.6 | GHSA-8v8j-3hxp-93wr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Spring | Spring Boot | 4.0.0 – before 4.0.6 |
Weakness: CWE-862, CWE-305 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
References
- https://spring.io/security/cve-2026-40976
- https://access.redhat.com/security/cve/CVE-2026-40976 vdb-entry, x_refsource_REDHAT
- RHBZ#2463322 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40976.json x_sadp-csaf-vex