Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M

CVE-2026-40941Cacti: Package Import Signature Validation Bypass Allows Self-Signed Packages

High 7.1

In plain English

A high-severity security flaw in cacti from Cacti. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.3%top 81.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have a package import signature validation bypass allows which allows self-signed packages. This issue has been fixed in version 1.2.31.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12cactino fix listedDEBIAN-CVE-2026-40941
Debian:13cactino fix listedDEBIAN-CVE-2026-40941
Debian:14cacti1.2.31+ds1-1DEBIAN-CVE-2026-40941
Ubuntu:24.04:LTScactino fix listedUBUNTU-CVE-2026-40941
Ubuntu:25.10cactino fix listedUBUNTU-CVE-2026-40941
Ubuntu:26.04:LTScactino fix listedUBUNTU-CVE-2026-40941
Ubuntu:26.10cactino fix listedUBUNTU-CVE-2026-40941

Affected products (as reported)

VendorProductVersions
Cacti cacti < 1.2.31

Weakness: CWE-347 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References