Vulnerability · Published May 22, 2026 · Assigned by GitHub_M
CVE-2026-40864JupyterHub: Cross-origin form POSTs bypass XSRF
Medium 5.4
In plain English
A medium-severity cross-site request forgery in jupyterhub from jupyterhub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. In versions 4.1.0 through 5.4.4, XSRF protection (updated in 4.1.0) inappropriately treated requests with Sec-Fetch-Mode: no-cors as same-origin requests, bypassing XSRF checks. The JSON API is not affected, only HTTP form endpoints, such as /hub/spawn and /hub/accept-share, meaning attackers could trigger server spawn (but not access the server) and if the attacker is a JupyterHub user permitted to share access to their server, cause a user to accept a share and have access to the attacker's server. This issue has been fixed in version 5.4.5. If developers are unable to immediately upgrade, they can temporarily mitigate this issue by dropping requests to JupyterHub with Sec-Fetch-Mode: no-cors if they are using a reverse proxy.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | jupyterhub | no fix listed | DEBIAN-CVE-2026-40864 |
| Debian:14 | jupyterhub | no fix listed | DEBIAN-CVE-2026-40864 |
| PyPI | jupyterhub | 5.4.5 | GHSA-m68r-v472-jgq9 |
| PyPI | jupyterhub | 5.4.5 | PYSEC-2026-2189 |
| Ubuntu:22.04:LTS | jupyterhub | no fix listed | UBUNTU-CVE-2026-40864 |
| Ubuntu:24.04:LTS | jupyterhub | no fix listed | UBUNTU-CVE-2026-40864 |
| Ubuntu:25.10 | jupyterhub | no fix listed | UBUNTU-CVE-2026-40864 |
| Ubuntu:26.04:LTS | jupyterhub | no fix listed | UBUNTU-CVE-2026-40864 |
| Ubuntu:26.10 | jupyterhub | no fix listed | UBUNTU-CVE-2026-40864 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jupyterhub | jupyterhub | >= 4.1.0, < 5.4.5 |
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L