Vulnerability · Published May 4, 2026 · Assigned by apache
CVE-2026-40682Apache OpenNLP: XXE via Dictionary Parsing in DictionaryEntryPersistor
Critical 9.1
In plain English
A critical-severity XML external entity in Apache OpenNLP from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XML External Entity (XXE) via Unsanitized Dictionary Parsing in Apache OpenNLP DictionaryEntryPersistor Versions Affected: before 2.5.9, before 3.0.0-M3 Description: The DictionaryEntryPersistor class initializes a static SAXParserFactory at class-load time without enabling FEATURE_SECURE_PROCESSING or disabling DTD processing. When create(InputStream, EntryInserter) is invoked, the only feature set on the XMLReader is namespace support — external entity resolution and DOCTYPE declarations remain fully enabled. An attacker who can supply a crafted dictionary file (e.g., a stop-word list or domain dictionary) containing a malicious DOCTYPE declaration can trigger local file disclosure via file:// entity references or server-side request forgery via http:// entity references during SAX parsing, before the application processes a single dictionary entry. This is inconsistent with the project's own XmlUtil.createSaxParser() helper, which correctly sets FEATURE_SECURE_PROCESSING and disallow-doctype-decl and is used by all other XML parsing paths in the codebase. The public Dictionary(InputStream) constructor delegates directly to this method and is the documented API for loading user-supplied dictionaries, making untrusted input a realistic scenario. Mitigation: 2.x users should upgrade to 2.5.9. 3.x users should upgrade to 3.0.0-M3. Users who cannot upgrade immediately should ensure that all dictionary files are sourced from trusted origins and should consider wrapping the Dictionary(InputStream) constructor with input validation that rejects any XML containing a DOCTYPE declaration before it reaches the parser.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | apache-opennlp | no fix listed | DEBIAN-CVE-2026-40682 |
| Debian:13 | apache-opennlp | no fix listed | DEBIAN-CVE-2026-40682 |
| Debian:14 | apache-opennlp | 2.5.9-1 | DEBIAN-CVE-2026-40682 |
| Maven | org.apache.opennlp:opennlp-tools | 2.5.9 | GHSA-4v8g-86x5-3vrc |
| Maven | org.apache.opennlp:opennlp-tools | 3.0.0-M3 | GHSA-4v8g-86x5-3vrc |
| Maven | org.apache.opennlp:opennlp-tools | 1.9.5 | GHSA-4v8g-86x5-3vrc |
| Ubuntu:22.04:LTS | apache-opennlp | no fix listed | UBUNTU-CVE-2026-40682 |
| Ubuntu:24.04:LTS | apache-opennlp | no fix listed | UBUNTU-CVE-2026-40682 |
| Ubuntu:25.10 | apache-opennlp | no fix listed | UBUNTU-CVE-2026-40682 |
| Ubuntu:26.04:LTS | apache-opennlp | no fix listed | UBUNTU-CVE-2026-40682 |
| Ubuntu:26.10 | apache-opennlp | no fix listed | UBUNTU-CVE-2026-40682 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache OpenNLP | 2.0 – before 2.5.93.0.0-M1 – before 3.0.0-M30 – before 1.9.5 |
Weakness: CWE-611 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
References
- https://lists.apache.org/thread/r6jpt0qr9nj67gqhppqg7jxf8vsbo0w6 vendor-advisory
- http://www.openwall.com/lists/oss-security/2026/05/01/19
- https://access.redhat.com/security/cve/CVE-2026-40682 vdb-entry, x_refsource_REDHAT
- RHBZ#2466484 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40682.json x_sadp-csaf-vex